После запуска Owen Logic на мониторе ПК открывается Главное окно:

Главное окно содержит:
- главное меню: Файл, Вид, Прибор, Сервис, Расширения, Помощь;
- панели инструментов;
- панели Библиотека компонентов, Свойства и Переменные (до открытия или создания проекта в них нет информации);
- рабочую область проекта – поле редактирования программы (до открытия или создания проекта пустое);
строку состояния в нижней части главного окна, показывающую информация о доступных ресурсах прибора и подключении к Owen Logic.
менеджер экранов
Главное меню
Файл
Новый проект | Создание нового проекта. Текущий проект закрывается, перед закрытием будет предложено сохранить проект |
Смена целевой платформы | Вызов окна смены модификации прибора для проекта |
Открыть проект | Открытие ранее созданного и сохраненного проекта |
Сохранить текущий документ | Сохранение текущего проекта |
Сохранить проект | Пересохранение проекта под текущим именем |
Сохранить проект как | Сохранение проекта под новым именем или в другом месте |
Создать файл с ключом | Создание файла с ключом (подробнее см. Защита проекта ключом) |
Сведения о проекте | Вызов окна сведений о проекте |
Создать макрос | Вызов редактора макросов |
Импорт из файла | Импорт макроса, функции или функционального блока на ST из файла в библиотеку компонентов |
Экспорт в файл | Экспорт макроса функции или функционального блока на ST для сохранения на ПК |
Менеджер компонентов | Вызов окна Менеджера компонентов |
Печать | Печать схемы открытого проекта |
Последние проекты | Список недавно открытых проектов |
Выход | Выход из Owen Logic |
Вид
Отменить | Отмена последнего действия в проекте |
Восстановить | Восстановление отмененного действия |
Индикаторы состояний | Включение/отключение индикаторов в строке состояний |
Панель библиотек | Скрыть/отобразить панель Библиотека компонентов |
Панель свойств | Скрыть/отобразить панель Свойства |
Переменные | Скрыть/отобразить панель Переменные |
Менеджер экранов | Скрыть/отобразить Менеджер экранов (меню доступно для приборов с дисплеем) |
Сбросить расположение панелей | Сброс пользовательских настроек положения панелей и возврат к настройкам по умолчанию |
Прибор
Записать программу в прибор | Запуск записи созданной программы в прибор (кнопка неактивна, пока не подключен прибор) |
Обновить встроенное ПО | Запуск обновления прошивки подключенного прибора |
Информация | Вызов окна с информацией о подключенном приборе |
Таблица переменных | Вызов окна для работы с переменными в проекте |
Юстировка входов/выходов | Вызов окна юстировки (кнопка неактивна, пока не подключен прибор) |
Настройка прибора | Вызов окна настройки прибора |
Настройка порта | Вызов окна настройки порта связи с прибором |
Сервис
Перенумеровать компоненты | Изменение нумерации ФБ в рабочей зоне проекта |
Режим симулятора | Запуск режима симуляции |
Режим OFFLINE | Включение/отключение запрета опроса прибора по USB |
Настройки
Настройка автоматического создания резервных копий проекта в фоновом режиме |
Расширения
Управление расширениями | Вызов окна управления расширениями |
Экспорт устройства в ОРС | Запуск расширения Экспорт устройства в ОРС |
Экспорт устройства в OwenCloud | Запуск расширения Экспорт устройства в OwenCloud |
Мастер тиражирования | Запуск расширения Мастер тиражирования |
Помощь
Автопроверка нового релиза | Включение/отключение автоматической проверки новых версий и релизов Owen Logic на сервере обновления |
Проверить обновления... | Вызов окна для проверки и установки новых версий и релизов Owen Logic |
Справка | Вызов окна справки |
История версий | Вызов в браузере страницы со списком версий ПО и описанием |
О программе | Вызов окна информации о текущей версии Owen Logic |
Панели инструментов
Панель инструментов

![]() | Новый проект | Создание нового проекта. Текущий проект закрывается, перед закрытием будет предложено сохранить проект |
![]() | Открыть проект | Открытие ранее созданного и сохраненного проекта |
![]() | Сохранить проект | Сохранение текущего проекта. При первом сохранении вызывает окно для присвоения имени файлу |
![]() | Печать | Печать схемы открытого проекта |
![]() | Копировать | Копирование выделенного в рабочей области элемента |
![]() | Вставить | Вставка скопированного элемента |
![]() | Отменить | Отмена последнего действия в проекте |
![]() | Восстановить | Восстановление отмененного действия |
![]() | Записать программу в прибор | Запуск записи созданной программы в прибор |
![]() | Информация | Вызов окна с информацией о подключенном приборе |
![]() | Настройки прибора | Вызов окна с настройками прибора |
![]() | Таблица переменных | Вызов окна для работы с переменными в проекте |
Панель отладки

![]() | Режим симулятора | Запуск режима симуляции |
![]() | Онлайн отладка | Запуск режима онлайн отладки |
![]() | Порядок исполнения | Изменение порядка вычисления значений на выходах программы или макроса и порядка передачи значений по обратным связям |
![]() | Перенумеровать компоненты | Изменение нумерации ФБ в рабочей зоне проекта |
Панель вставки

![]() | Блок комментариев | Добавление комментария на схему проекта |
![]() | Создание блока выходной переменной | Создание блока для записи значения в переменную |
![]() | Создание блока входной переменной | Создание блока для считывания значения из переменной |
![]() | Создание блока константы | Создание блока с фиксированным числовым значением |
![]() | Линия задержки | Создание задержки на 1 цикл |
![]() | Создание сетевой выходной переменной | Создание блока переменной, значение которой задается по сети |
![]() | Создание сетевой входной переменной | Создание блока переменной, значение которой считывается по сети |
![]() | Создание блока записи в ФБ | Создание блока для записи значения переменной ФБ, на схеме может не отображаться соединительная линия цепи передачи сигнала |
![]() | Создание блока чтения из ФБ | Создание блока для считывания значения переменной ФБ, на схеме может не отображаться соединительная линия цепи передачи сигнала |
![]() | Преобразователь в булевское значение | Конвертация значения сигнала в булевское значение |
![]() | Преобразователь в целочисленное значение | Конвертация значения сигнала в целочисленное значение |
![]() | Преобразователь в число с плавающей точкой | Конвертация значения сигнала в число с плавающей точкой |
![]() | Создать макрос | Создание нового макроса в проекте |
![]() | Создать функцию на ST | Создание функции на языке ST для использования в проекте |
![]() | Создать функциональный блок на ST | Создание функционального блока на языке ST для использования в проекте |
Панель Библиотека компонентов
Включить/выключить отображение панели Библиотека компонентов в рабочей области можно в главном меню Вид.
Если в Owen Logic открыт проект, то на панели Библиотека компонентов отображаются ее разделы:
Раздел выбирается в нижней части панели.

Вид
В выпадающем меню можно выбрать вид расположения компонентов:

Способ отображения компонентов можно выбрать с помощью кнопок в верхней части панели:
Показать все
компоненты – отображаются все компоненты выбранного раздела;
Группировка
по папкам – отображаются папки, содержащие компоненты разных типов.
Описание разделов и компонентов панели Библиотека компонентов приведено в разделе Библиотека.
Панель Свойства
Включить/выключить отображение панели Свойства в рабочей области можно в главном меню Вид.
На панели отображаются и редактируются:
- параметры элементов программы;
- размеры холста;
- часто используемые свойства входов и выходов (полный перечень свойств находится в разделе Входы настроек прибора);
- параметры комментария, свободных переменных, блоков преобразователей.
Если элемент не выбран, то на панели отображаются свойства холста.
Для отображения свойств элемента в панели следует нажать на него ЛКМ.

Способы отображения параметров в панели:
— в алфавитном
порядке;
— по категориям.
Панель переменных
Включить/выключить отображение Панели переменных в рабочей области можно в главном меню Вид.
На Панели переменных отображаются переменные из Таблицы переменных.

![]() | Раскрыть подкаталоги |
![]() | Свернуть подкаталоги |
Раскрыть/свернуть один каталог можно с помощью частных кнопок + / -, расположенных перед иконкой каталога.
Создание блока переменной
Для создания блока входной переменной следует перетащить переменную (методом drag & drop) на холст.
Для создания блока выходной переменной следует перетащить переменную на холст, удерживая клавишу Shift.
Можно перетаскивать на холст сразу несколько переменных. Для этого предварительно выделите их на панели переменных.
Способы выделения переменных:
CTRL + ЛКМ по переменным. Каждый клик добавляет переменную в выделение или исключает её, если она уже выделена.
SHIFT + стрелки ↓ / ↑. Не выделенные переменные выделяются, с уже выделенных выделение снимается. Каталоги/подкаталоги не выделяются.
Выделение диапазона (SHIFT). Нажмите ЛКМ по первой переменной диапазона, затем, удерживая SHIFT, нажмите ЛКМ по последней. Все переменные между ними (включительно) будут выделены.
Если переменную перетащить к коннектору элемента схемы, то будет создан блок переменной, присоединенный к этому коннектору. Если к коннектору элемента схемы перетащить несколько выделенных переменных, связь с коннектором создана не будет.
Ссылки
Для отображения блоков, к которым привязана переменная, следует нажать на имя переменной в панели. В области ссылок панели отобразятся ссылки на блоки. Если кликнуть по ссылке, то на холсте будет выделен блок, к которому привязана переменная.

С помощью контекстного меню переменной можно найти переменную в Панели переменных, для этого следует выбрать пункт Найти в Панели переменных. Привязки переменной к другим блокам можно просмотреть в пункте Показать ссылки контекстного меню блока переменной. Если нажать на ссылку в контекстном меню, то будет совершен переход к выбранному блоку.

Рабочая область
После создания проекта или открытия сохраненного проекта в рабочей области появляется холст для разработки программы на языке FBD.
Если прибор поддерживает работу с функциями на языке ST, отобразится вкладка Редактор функции.

На холсте размещаются элементы и блоки из панели Библиотека компонентов и панели вставки. Изменить размеры холста можно на панели Свойства.
Входы и выходы
Входы и выходы прибора обозначены в виде квадратов с маркировкой номеров:
вдоль левого края холста расположены входы (Ix — дискретные, FIx — быстрые дискретные, AIx — аналоговые);
вдоль правого края холста расположены выходы (Qx — дискретные, AOx — аналоговые, К — ключи, Fx — светодиоды).
Цифры в обозначениях соответствуют номерам физических входов и выходов прибора. Входы и выходы можно перетаскивать вверх/вниз вдоль холста методом drag & drop, удалять и добавлять для удобства компоновки схемы.

Управление
Над холстом располагаются кнопки:
![]() | Включить/Выключить сетку | При включенной сетке на холсте отображаются вертикальная и горизонтальная линейки и сетка. Элементы и линии связи при размещении привязываются к сетке |
![]() | Уменьшить масштаб | Уменьшение масштаба на 10 % от первоначального |
![]() | Оригинальный размер | Возврат к исходному масштабу |
![]() | Увеличить масштаб | Увеличение масштаба на 10 % от первоначального |
Задать требуемый масштаб можно с помощью выпадающего меню справа от описанных выше кнопок.
В нижней части холста находятся кнопки:
| Используется для одновременного отображения двух областей одной схемы в разных окнах |
| Используется для отображения схемы в одном окне |
Строка состояния
В строке состояния отображается информация о доступных ресурсах прибора и подключении.
Вид
В зависимости от прибора, выбранного при создании проекта, перечень индикаторов в строке состояния может различаться.

Индикаторы
Настройка отображения индикаторов в строке состояния доступна через Главное меню → Вид → Индикаторы состояний.
В строке состояния может отображаться следующая информация:
- ФБ — доступное количество экземпляров функциональных блоков;
- Перем. — доступное количество переменных;
- Стек — уровень использования памяти выделенной под стек. Стек используется для промежуточных вычислений в программе;
- Сист. ЭСППЗУ — доступное количество системной энергонезависимой памяти. Индикатор заполняется в случае использования сетевых переменных на схеме, привязки переменных к визуализации и параметрам прибора и добавления в проект модулей расширения;
- ЭСППЗУ — доступное количество энергонезависимой памяти. Индикатор заполняется в случае использования на схеме стандартных энергонезависимых переменных;
- ПЗУ — доступное ПЗУ прибора в процентах от общего объема: «ПЗУ: 0…100 %»;
- Сист. ОЗУ — доступное системное ОЗУ прибора.
- ОЗУ
— доступное ОЗУ прибора в процентах от общего объема: «ОЗУ: 0…100 %». Чем больше используется в программе блоков и функций, тем больше памяти требуется для работы в приборе. Owen Logic автоматически рассчитывает доступную память прибора и в случае критического значения выводит соответствующее предупреждение;
Сист. ПЗУ визуал. — доступное ПЗУ визуализации прибора в процентах от общего объема (только для приборов с графическим цветным ЖКИ);
Польз. ПЗУ визуал. — доступное ПЗУ визуализации для растровых изображений (только для приборов с графическим цветным ЖКИ);
ОЗУ визуал. — доступное ОЗУ визуализации прибора в процентах от общего объема. Расчет ведется для самого нагруженного экрана (только для приборов с графическим цветным ЖКИ);
- ПРххx-xхх — модель подключенного прибора. Если прибор не подключен, на индикаторе отображается надпись Прибор не подключен. Нажатие на индикатор включает/выключает режим OFFLINE;
- COMx — номер выбранного пользователем порта для подключения прибора. Нажатие на индикатор открывает окно настройки порта.
При наведении мышки на индикатор отображается всплывающее сообщение с информацией о загрузке памяти прибора.
Режим OFFLINE
В режиме OFFLINE устанавливается запрет на связь с прибором.
Для перехода в режим OFFLINE следует нажать на индикатор модели прибора в строке состояния или выбрать в главном меню Сервис → Режим OFFLINE. Вид индикатора изменится на OFFLINE. Повторное нажатие отключает режим OFFLINE.
Подробнее см. в разделе Загрузка в прибор.
Менеджер и редактор экранов
Менеджер экранов
Если прибор оснащен дисплеем, то на него можно запрограммировать вывод информации из программы. Инструкция по работе с экранами приведена в разделе Программирование экрана прибора.
Включить/выключить отображение вкладки Менеджер экранов в рабочей области можно в главном меню Вид.
Менеджер экранов открывается нажатием на одноименную вкладку в левом крае рабочей области.

Менеджер экранов состоит из дерева элементов в верхней части и полей свойств в нижней части.
В дереве экранов отображаются и редактируются группы экранов и экраны.
Основные функции:
![]() | Добавить экран (находится в верхней части менеджера экранов и в контекстном меню группы экранов приборов с графическим цветным ЖКИ) |
![]() | Удалить элемент (находится в верхней части менеджера экранов, в контекстном меню экрана и группы экранов приборов с графическим цветным ЖКИ) |
![]() | Удалить экран (в контекстном меню экрана) |
![]() | Редактировать экран (в контекстном меню экрана) |
![]() | Редактировать группу (в контекстном меню группы экранов, доступен только для приборов с монохромным текстовым ЖКИ) |
При выборе экрана или группы экранов в нижней части Менеджера экранов отображаются их свойства.
Редактор экранов
Редактор экранов открывается выбором команды Редактировать экран в контекстном меню экрана в Менеджере экранов или двойным нажатием ЛКМ по экрану в дереве экранов.


Подробно работа с экранами рассмотрена в разделах:











































