Загрузка проекта и режим эмуляции

Загрузка проекта с ПК

Graphic
Окно загрузки проекта

Для панелей базовых модификаций (-Б) загрузка проекта выполняется через интерфейс USB B. Перед началом загрузки нужно подключить панель к ПК с помощью кабеля USB B – USB A.

Для панелей расширенных модификаций (-Р) загрузка проекта выполняется через интерфейс Ethernet.  Перед началом загрузки:

  • панель должна быть подключена к той же локальной сети, что и ПК (или напрямую к сетевому адаптеру ПК);

  • для панели должны быть заданы сетевые настройки, соответствующие локальной сети (с помощью системного меню или экранного конфигуратора).

Для загрузки проекта следует использовать команду Файл – Загрузить проект или соответствующий ярлык на панели ярлыков. Доступны следующие кнопки:

  • Загрузить – выполняет загрузку проекта.

  • Выгрузить – выполняет попытку выгрузки.

  • Закрыть – закрывает окно загрузки.

Примечание
Для панелей базовой модификации (-Б) загрузка проекта возможна только в том случае, если к порту USB A не подключен USB-накопитель.
Настройки меню Загрузка проекта

Параметр

Описание

Тип соединения

USB или Ethernet

Поиск по IP

IP-адрес панели, в которую будет загружен проект

Поиск по ID

Идентификатор панели (отображается в системном меню или экранном конфигураторе), в которую будет загружен проект

Пароль на загрузку

Пароль, который требуется для загрузки проекта. Задаётся в системном меню или экранном конфигураторе. Значение по умолчанию – 123456

Сканировать

Данная кнопка доступна только при подключении по Ethernet. При нажатии кнопки ПК отправляет UDP-пакет на широковещательный адрес сети (порт 3333), в результате чего его получают все панели. Результаты сканирования отображаются в виде таблицы с указанием имени панели, IP-адреса, идентификатора и модификации

Тест связи

При нажатии на кнопку происходит проверка связи с панелью (отправка ping-запроса), после чего отображается соответствующее информационное сообщение

Разрешить выгрузку

В случае установки галочки загружаемый проект будет доступен для выгрузки

Пароль на выгрузку

Пароль, который требуется для выгрузки проекта. Может быть изменен в системном меню или экранном конфигураторе

Установить загрузочное изображение

В случае установки галочки можно выбрать изображение формата .jpg или .bmp, которое будет отображаться на дисплее панели в процессе её загрузки

Стандартное загрузочное изображение

В случае установки галочки в процессе загрузки панели на её дисплее будет отображаться стандартное изображение с логотипом ОВЕН

Синхронизировать время с ПК

В случае установки галочки при загрузке проекта в часы панели будет установлено системное время ПК

Очистить историю тревог

В случае установки галочки при загрузке проекта будут удалены файлы истории тревог

Перезаписать рецепты

В случае установки галочки при загрузке проекта значения в файлах рецептов будут заменены на значения из загружаемого проекта

Скрыть системное меню

В случае установки галочки после загрузки проекта у пользователя не будет возможности перейти в системное меню (кнопка Настройки не будет отображаться)

Очистить журнал действий

В случае установки галочки при загрузке проекта будет очищен журнал действий оператора

Загрузить шрифты

В случае установки галочки при загрузке проекта в память панели будут загружены файлы шрифтов, использованных в настройках графических элементах, но отсутствующих в панели

Включить контроль оплаты

В случае установки галочки при загрузке проекта будет включена функция контроля оплаты

Очистить выборку данных

В случае установки галочки при загрузке проекта будут удалены файлы выборки данных

Очистить PFW/SPFW

В случае установки галочки при загрузке проекта значения всех регистров PFW будут обнулены и установлены значения, заданные в меню Данные PFW-регистров, а значения регистров SPFW – установлены в значения по умолчанию

Загрузка проекта с USB-накопителя

Для загрузки проекта с USB-накопителя следует:

  • выполнить команду Файл – Создать загрузочный проект. Установить нужные галочки и указать путь к создаваемому файлу. Название файла не должно содержать символов кириллицы, пробелов и спецсимволов;

    Graphic
    Окно создания загрузочного проекта
  • полученный файл с расширением .dat скопировать на USB-накопитель. Требования к USB-накопителю: файловая система FAT32, объём – не более 32 Гб;

  • подключить USB-накопитель к включенной панели;

  • в открывшемся окне нажать на кнопку Обновление проекта и указать путь к файлу .dat;

  • после загрузки проект будет автоматически запущен.

Эмуляция

Режим эмуляции позволяет проверить работу проекта без реальной панели. Существует два варианта эмуляции: offline-эмуляция и online-эмуляция.

Graphic
Окно запуска эмуляции
Сравнение возможностей offline-эмуляции и online-эмуляции

Параметр

Offline-эмуляция

Online-эмуляция

Проверка обмена с другими устройствами

Не поддерживается

Поддерживается, в режимах Master и Slave

Время непрерывной работы

Без ограничений

2 часа

(после этого эмулятор можно перезапустить)

В режиме эмуляции не поддерживается:

Рабочая директория эмулятора в директории установки конфигуратора: \Temp

Директория, соответствующая USB-накопителю: \Temp\Run\Storage\udisk

Для запуска эмуляции используются команды меню Файл или соответствующие ярлыки панели ярлыков.

При запуске online-эмуляции последовательно появляются два диалоговых окна:

  • В первом производится маппинг COM-портов. Пользователь должен указать, какие COM-порты ПК будут соответствовать COM-портам, использованным в проекте панели (COM1 и COM2).

    Graphic
    Маппинг COM-портов
    Graphic
    Маппинг COM-портов
  • Во втором окне доступны галочки, описанные в таблице:

    • очистить историю тревог;

    • очистить выборку данных;

    • перезаписать рецепты;

    • очистить журнал действий;

    • очистить PFW/SPFW.

Cохранение эмуляции

С помощью команды Файл – Сохранить эмуляцию окружение online-эмуляции сохраняется в виде набора файлов, которые можно перенести на другой ПК. Это позволяет запустить эмуляцию на компьютере, на котором не установлен конфигуратор (например, для демонстрации функционала заказчику).

Graphic
Окно сохранения эмуляции

В открывшемся окне следует указать директорию ПК, в которой будут сохранены файлы конфигурации, и название исполняемого файла. Описание доступных галочек приведено в таблице.

Для запуска эмуляции на другом ПК следует перенести на него содержимое указанной выше директории и запустить файл с расширением .exe. При запуске появится окно маппинга COM-портов (см. рисунок, рисунок).

Время работы online-эмуляции ограничено 2 часами. После этого эмулятор можно перезапустить.