Основная информация
После создания нового проекта окно конфигуратора будет выглядеть следующим образом:

Окно включает в себя следующие области:
панель меню – содержит пункты меню для работы с проектом;
панель ярлыков – содержит ярлыки, дублирующие наиболее часто используемые команды меню;
дерево проекта – содержит список используемых в проекте экранов, окон и макросов, а также ярлыки для доступа к библиотекам проекта;
панель элементов – дублирует ярлыки элементов визуализации из меню Графика и Элементы;
редактор визуализации – позволяет добавлять на экраны и окна графические элементы и настраивать их параметры;
карта адресов используемых в проекте битов и регистров с возможностью перехода к элементам, к которым они привязаны;
список элементов открытого в редакторе визуализации экрана/окна;
панель сообщений – содержит сообщения и ошибки компиляции;
строка информации – содержит информацию о модификации и IP-адресе панели (с возможностью перехода к окнам их выбора), настроенных протоколах обмена, а также кнопки для управления масштабом и видимостью сетки редактора визуализации.
Дерево проекта, панель элементов, карта адресов, список элементов и панель сообщений являются докируемыми окнами, которые можно перемещать по экрану и закреплять в различных областях в доступных для этого слотах.
Для возвращения вида графического интерфейса в состояние «по умолчанию» используется команда Вид – Восстановить интерфейс по умолчанию.
Панель меню

Панель меню включает в себя следующие пункты:
Файл – содержит команды для работы с проектом и эмулятором. Команда Настройки проекта отвечает за выбор модификации панели, создание пользователей, настройку обмена с другими устройствами и др.;
Правка – содержит команды для работы с графическими элементами (копирование, вставка, удаление, замена привязанных к элементам адресов битов/регистров и т. д.);
Элементы – содержит графические элементы, используемые для создания визуализации проекта (индикаторы, кнопки, элементы отображения и ввода и т. д.);
Графика – содержит отдельную группу наиболее простых графических элементов (линии, прямоугольники и т. д.), элементы отображения внешних графических файлов и некоторые другие элементы;
Инструменты – содержит команды доступа к библиотекам проекта, а также команды перехода к настройкам функции Контроль оплаты, окну настроек конфигуратора и команду для подключения к панели с целью настройки сервисов MQTT и VNC;
Вид – содержит кнопки скрытия/отображения отдельных областей конфигуратора;
Справка – содержит команду вызова справки по работе с конфигуратором и информацию о текущей версии конфигуратора.
Панель ярлыков

Панель ярлыков содержит ярлыки для выполнения:
команд Cоздать, Открыть, Сохранить, Закрыть, Загрузить, Online-эмуляция, Offline-эмуляция, Компилировать, Настройки проекта (из меню Файл);
команд Отменить, Повторить, Копировать, Вырезать, Вставить, Удалить, Поиск и замена (из меню Правка);
команд Выборка данных, Тревоги, Рецепты, Журнал действий (из меню Элементы);
команды Контроль оплаты (из меню Инструменты);
команды Масштаб по умолчанию, которая восстанавливает исходный масштаб редактора визуализации.

Также панель содержит выпадающие списки:
F – изменение шрифта и размера текста выделенных в редакторе визуализации элементов;
S – изменение состояния всех отображаемых в редакторе элементов (например, чтобы посмотреть, как будут выглядеть кнопки в нажатом/отжатом состоянии);
L – изменение языка всех отображаемых в редакторе элементов (например, чтобы посмотреть, как будет выглядеть экран в случае переключения языка и проверить, вписываются ли тексты локализации в размеры элементов).
Дерево проекта

Дерево проекта содержит следующие узлы:
Пользовательские экраны – создаваемые пользователем экраны графического интерфейса оператора;
Пользовательские окна – создаваемые пользователем окна, открываемые поверх экранов графического интерфейса оператора;
Системные экраны – экраны экранного конфигуратора;
Системные окна – окна системных сообщений и диалогов ввода (клавиатур);
Макросы – заголовочные файлы и файлы исходного кода на языке C, используемые в рамках данного проекта;
Библиотеки – библиотеки ресурсов проекта: текстов, переменных, изображений и аудиофайлов;
Устройства – узел Настройки проекта, нажатие на который открывает меню Файл – Настройки проекта – Устройства, в котором настраивается обмен с другими устройствами.
Для добавления пользовательского экрана следует нажать ПКМ на узел Пользовательские экраны и использовать команду Добавить. Откроется окно настроек экрана:

Настройки пользовательского экрана
Параметр | Описание |
|---|---|
Название | Название экрана. Отображается в дереве проекта, используется в действии Переход на экран элементов Функциональная кнопка/Функциональная область и в меню настроек проекта на вкладке Общее (см. параметры Начальный экран и Экран заставки) |
Номер экрана | Номер экрана. Используется в макросах в функции ScreenJump, в действии Переход на экран элементов Функциональная кнопка/Функциональная область и при работе с параметром Номер открытого экрана. |
Цвет фона | Цвет фона экрана |
Ширина и высота | Ширина и высота экрана. Определяются разрешением выбранной модификации панели оператора (недоступны для изменения) |
Подложка | Выбор экрана и окна, содержимое которых будет отображаться в верхнем и нижнем слое данного экрана. Порядок отображения слоев (от верхнего к нижнему):
В редакторе визуализации элементы подложки отображаются более серыми по сравнению с элементами самого экрана |
Уровень доступа | Уровень доступа, необходимый для перехода на данный экран |
Изменить требуемый уровень доступа при закрытии | Если установлена галочка, то после перехода с данного экрана на другой экран, требуемый для перехода на данный экран уровень доступа будет изменен на заданный |
Максимальное количество пользовательских экранов в проекте – 5000.
Для добавления пользовательского окна следует нажать ПКМ на узел Пользовательские окна и использовать команду Добавить. Откроется окно настроек:

Большая часть настроек аналогична настройкам экрана. В таблице приведены настройки, присутствующие только у окна:
Настройки пользовательского окна
Параметр | Описание |
|---|---|
Окно-клавиатура | В случае установки галочки создаваемое окно может использоваться в качестве клавиатуры ввода для элементов типа Цифровой ввод и Текстовый ввод |
По центру экрана | Окно будет открываться по центру экрана |
По координатам | Окно будет открываться по заданным координатам (которые соответствуют положению левой верхней точки открытого окна) |
Модальное | В случае установки галочки элементы на экране, поверх которого открыто данное окно, становятся недоступны для нажатия до закрытия окна |
С кнопкой закрытия | В случае установки галочки в верхнем правом углу окна будет отображаться кнопка закрытия |
Перемещаемое | В случае установки галочки открытое окно можно перемещать по экрану, зажав курсор в любом свободном месте окна |
Максимальное количество пользовательских окон в проекте – 5000.
Для изменения настроек созданного ранее экрана или окна следует нажать на нем ПКМ в дереве проекта, или на его фон в редакторе визуализации и использовать команду Свойства.
В контекстном меню, открываемом при нажатии на ПКМ в дереве проекта на экран/окно, также доступны следующие команды:
Копировать – копирует объект в буфер обмена. Для вставки объекта следует нажать ПКМ на узел Пользовательские экраны или Пользовательские окна, и использовать команду Вставить;
Закрыть – закрывает вкладку экрана/окна в редакторе визуализации;
Удалить – удаляет данный экран/окно.
Объекты и команды, связанные с макросами, описаны в пункте Макросы.
Объекты библиотек описаны в пункте Библиотеки.
Узел Устройства описан в пункте Настройка обмена с другими устройствами.
Системные экраны и окна
Узел Системные экраны включает в себя экраны, используемые в экранном конфигураторе панели. Узел Системные окна включает в себя окна, связанные с системными экранами, а также окна авторизации пользователей, диагностических сообщений и клавиатур.
Создание и удаление системных экранов и окон не доступно для пользователя. Внешний вид существующих экранов и окон может быть изменён в проекте панели (см. в дереве проекта узел «Системные экраны»).
Также для системных экранов и окон доступны те же команды контекстного меню, что и для пользовательских экранов и окон. Вставка скопированного в буфер обмена системного экрана/окна возможна только в узел Пользовательские экраны/Пользовательские окна соответственно.
Список системных экранов
№ | Название | Описание |
|---|---|---|
20001 | Информация | Информация о панели – модификация, версия ПО и т. д. |
20002 | Системное время | Установка системного времени |
20003 | Сетевые настройки | Изменение сетевых настроек (только для панелей расширенных модификаций) |
20004 | Пароли | Изменение паролей |
Список системных окон
№ | Название | Способ открытия |
|---|---|---|
25001 | Авторизация |
|
25002 | Ограничение доступа | При нажатии на элемент, для которого не хватает уровня доступа (в случае установки галочки Открыть окно авторизации, если не хватает уровня доступа в настройках элемента) |
25003 | Ошибки обмена | От системного бита SPSB48 |
25005 | Системное предупреждение | От системного бита SPSB3 |
25006 | Подтверждение выполнения | При нажатии на элемент, в настройках которого установлена галочка Подтверждение операции |
25014 | Изменение пароля | Вручную пользователем |
25015 | Экспорт данных на USB-накопитель | В случае экспорта, настроенного в элементе (например, элементе Тренд) |
25017 | Результат изменения сетевых настроек | В случае изменения сетевых настроек на системном экране 20003 |
25018 | Результат изменения системного времени | В случае изменения системного времени на системном экране 20002 |
25111 | Изменение конфигурации OPC UA Server | В случае изменения сетевых настроек или логинов/паролей пользователей |
25007 | KeyBoard_Asc_01U | Текстовая клавиатура с верхним регистром клавиш, стиль 1 |
25008 | KeyBoard_Asc_01L | Текстовая клавиатура с нижним регистром клавиш, стиль 1 |
25009 | KeyBoard_Num_01UL | Цифровая клавиатура с отображением минимально и максимально допустимого значения, стиль 1 |
25010 | KeyBoard_Num_01 | Цифровая клавиатура, стиль 1 |
25011 | KeyBoard_Hex_01 | Цифровая клавиатура с HEX-символами, стиль 1 |
25012 | KeyBoard_Asc_02U | Текстовая клавиатура с верхним регистром клавиш, стиль 2 |
25013 | KeyBoard_Asc_02L | Текстовая клавиатура с нижним регистром клавиш, стиль 2 |
25100 | KeyBoard_Asc_03U | Текстовая клавиатура с верхним регистром клавиш, стиль 3 |
25101 | KeyBoard_Asc_03L | Текстовая клавиатура с нижним регистром клавиш, стиль 3 |
25102 | KeyBoard_Asc_04U | Текстовая клавиатура с верхним регистром клавиш, стиль 4 |
25103 | KeyBoard_Asc_04L | Текстовая клавиатура с нижним регистром клавиш, стиль 4 |
25104 | KeyBoard_Num_02UL | Цифровая клавиатура с отображением минимально и максимально допустимого значения, стиль 2 |
25105 | KeyBoard_Hex_02 | Цифровая клавиатура с HEX-символами, стиль 2 |
25106 | KeyBoard_Num_02 | Цифровая клавиатура, стиль 2 |
25112 | KeyBoard_Asc_01Ru_U | Текстовая клавиатура с верхним регистром клавиш и поддержкой кириллицы, стиль 1 |
25113 | KeyBoard_Asc_01Ru_L | Текстовая клавиатура с нижним регистром клавиш и поддержкой кириллицы, стиль 1 |
25114 | KeyBoard_Asc_02Ru_U | Текстовая клавиатура с верхним регистром клавиш и поддержкой кириллицы, стиль 2 |
25115 | KeyBoard_Asc_02Ru_L | Текстовая клавиатура с нижним регистром клавиш и поддержкой кириллицы, стиль 2 |
25116 | KeyBoard_Asc_03Ru_U | Текстовая клавиатура с верхним регистром клавиш и поддержкой кириллицы, стиль 3 |
25117 | KeyBoard_Asc_03Ru_L | Текстовая клавиатура с нижним регистром клавиш и поддержкой кириллицы, стиль 3 |
25118 | KeyBoard_Asc_04Ru_U | Текстовая клавиатура с верхним регистром клавиш и поддержкой кириллицы, стиль 4 |
25119 | KeyBoard_Asc_04Ru_L | Текстовая клавиатура с нижним регистром клавиш и поддержкой кириллицы, стиль 4 |
Библиотеки
Узел Библиотеки содержит ресурсы проекта:
тексты локализации;
переменные;
изображения;
аудиофайлы (только для модификаций СП210-07-Р, СП210-10-Р, СП210-15-Р).
Для перехода в библиотеку следует два раза нажать ЛКМ на узел нужной библиотеки в дереве проекта или использовать команду меню Инструменты.
Библиотека локализации
Библиотека локализации содержит тексты, привязываемые к графическим элементам проекта, с их переводом на разные языки. В проекте может быть использовано до 8 языков. Для переключения языка в процессе работы проекта используется системный регистр SPFW260.
Библиотека содержит две вкладки: Метки и Мультиязычность.

Метки используются для создания текстов элементов, которые имеют 2 и более состояния – например, Индикатор, Переключатель, Переключатель с индикацией, Многопозиционный индикатор, Многопозиционный переключатель и т. д.
Мультиязычные тексты используются для создания отдельных текстов элементов Статический текст, Динамический текст, Таблица данных и т. д.
Мультиязычные тексты распределяются по таблицам.

Для создания, удаления, копирования и вставки меток, их состояний и мультиязычных текстов используются соответствующие команды. Строка поиска позволяет осуществить поиск по меткам и мультиязычным текстам.
Команда Экспорт позволяет выгрузить метки и мультиязычные тексты в виде файла формата .xlsx c расширением .xlsx, .xls или .csv (расширение не влияет на формат файла). Команда Импорт позволяет загрузить файл.
Библиотека переменных
Библиотека переменных содержит переменные, привязываемые к графическим элементам и некоторым настройкам проекта.
Библиотека содержит три вкладки: системные переменные, пользовательские переменные и переменные устройств.
Системные переменные
Системные переменные представляют собой предопределённый набор переменных, позволяющих считывать и записывать параметры панели. Такие переменные не могут быть созданы, удалены или отредактированы пользователем. Системные переменные размещаются в областях памяти SPSB (системные биты), SPSW (системные оперативные регистры) и SPFW (системные энергонезависимые регистры).

Таблица системных переменных содержит следующие столбцы:
имя переменной;
категорию;
адрес;
тип данных;
тип доступа (только чтение/только запись/чтение и запись);
флаг энергонезависимости (принадлежности к области SPFW) переменной.
C помощью команды
можно осуществить фильтрацию таблицы по категории, типу данных,
типу доступа и флагу энергонезависимости.
С помощью строки поиска можно осуществить поиск переменной по имени и категории.
Список системных переменных приведён в пункте.
Пользовательские переменные
Пользовательские переменные создает разработчик проекта панели.

Галочка Передавать по MQTT экспортирует выбранную переменную в список параметров протокола MQTT, а галочка Передавать всё по MQTT осуществляет экспорт всех переменных сразу (только для расширенных модификаций панелей (-Р).
Команда Экспорт позволяет выгрузить переменные в виде файла формата .xlsx. Команда Импорт позволяет загрузить файл.

При создании переменой следует указать:
имя переменной;
тип данных;
описание;
место хранения значения. Например, память одного из slave-устройств, подключенных к панели, или ее внутренние регистры;
адрес slave-устройства (если переменная хранится в его памяти);
формат;
динамический адрес.
С помощью строки поиска можно осуществить поиск переменной по имени и области памяти.
Переменные устройств
В списке переменных устройств отображаются переменные, импортированные по протоколу CODESYS V3 (PLC Handler) или OPC UA Client. Для выбора переменных конкретного устройства используется выпадающий список. Пользователь может удалить из списка те переменные, которые не требуются в его проекте.

Таблица переменных содержит следующие столбцы:
путь переменной;
тип данных;
описание.
С помощью строки поиска можно осуществить поиск переменной по имени (имя – последний сегмент пути; по другим сегментам пути осуществить поиск нельзя).
Библиотека изображений
Библиотека изображений содержит изображения, которые могут использоваться при создании проекта. У большинства графических элементов выбор изображения осуществляется на вкладке параметров Вид. Кроме того, существует несколько элементов, рассчитанных на отображение графических файлов – Изображение и Динамическое изображение.

Окно библиотеки изображений состоит из трёх областей:
дерева папок библиотеки;
списка изображений выбранной в данный момент папки;
списка настроек выбранного в данный момент изображения.
Создание/удаление/переименование папок и добавление/удаление изображений происходит с помощью команд контекстного меню дерева папок. Ярлыки команд также продублированы над списком изображений.
Добавление изображений возможно только в созданные пользователем папки.
Удаление папки со стандартными изображениями и самих изображений пользователю не доступно.
Поддерживаемые форматы изображений: .svg, .png, .jpg, .jpeg, .bmp.
Фактически библиотека изображений представляет собой папку \Resource\Pic в директории установки конфигуратора. В зависимости от настроек операционной системы, для работы с библиотекой изображений может потребоваться запуск конфигуратора с правами администратора.
Для стандартных .svg изображений доступны настройки типа заливки (однотонная или градиент) и цвета заливки. Для некоторых из них также доступны настройки типа и цвета заливки контура. В случае создания пользовательских изображений следует учитывать:
цвету элемента соответствует параметр SVG c id="color1";
цвету контура – параметр с id="color2".
Библиотека аудиофайлов
Библиотека аудиофайлов доступна только для модификаций СП210-07-Р, СП210-10-Р, СП210-15-Р. Библиотека содержит аудиозаписи, которые могут воспроизводиться при нажатии на элемент Переключатель, Переключатель с индикацией, Ввод символа, Функциональная кнопка, а также при активации тревог.

Окно библиотеки аудиофайлов состоит из двух областей:
дерева папок библиотеки;
списка файлов выбранной в данный момент папки.
Для создания папки используется команда контекстного меню дерева
папок. Для импорта существующей папки используется ярлык
. Для добавления
аудиофайла нужно нажать ПКМ на область списка файлов и использовать
команду Добавить файл или использовать ярлык
. Для удаления папки или файла
используется соответствующая команда контекстного меню или ярлык
.
Поддерживаемые форматы аудиофайлов: .mp3, .wav.
Размер файла не должен превышать 3 Мб.
В списке файлов отображаются названия, размеры и кнопки воспроизведения.
Фактически библиотека аудиофайлов представляет собой папку \Resource\Sound в директории установки конфигуратора. В зависимости от настроек операционной системы для работы с библиотекой изображений может потребоваться запуск конфигуратора с правами администратора.
Редактор визуализации
Редактор визуализации позволяет добавлять на экраны и окна проекта графические элементы и настраивать их параметры.

Графические элементы доступны на панели меню в разделах Элементы и Графика, а также на панели элементов. В зависимости от типа элемента добавление производится разными способами:
для большинства элементов размещение на экране/окне производится путём выбора элемента и однократного нажатия ЛКМ в нужной области экрана/окна;
для элементов Прямоугольник и Окружность при зажатой ЛКМ следует отрисовать контур элемента;
для элементов Линия, Дуга, Ломаная/Многоульник, Анимация перемещения и Трубопровод каждое нажатие ЛКМ будет приводить к созданию новой опорной точки элемента. Для завершения следует два раза нажать ЛКМ.
После добавления элемента автоматически открывается окно свойств.
Элементы могут быть размещены за пределами «видимой» части экрана/окна. Это удобно для размещения невизуализируемых элементов — таких, как Функциональная область, Подсветка и Зуммер.
Над элементом отображается идентификатор, имена привязанных переменных и адреса привязанных битов/регистров. Управление видимостью и настройками отображения информации осуществляется в меню Инструменты – Настройки конфигуратора.
Для перемещения выделенного элемента по экрану следует зажать ЛКМ и переместить курсор в нужное место. Для изменения размера следует зажать ЛКМ на одной из опорных точек элемента и переместить курсор на нужное расстояние. Для некоторых элементов доступна опорная точка (жёлтого цвета), позволяющая вращать элемент вокруг своей оси.
При работе с элементами можно использовать команды меню Правка.
Вкладки
В верхней части редактора размещаются вкладки открытых экранов/окон. При нажатии ПКМ на вкладку открывается контекстное меню, в котором доступны команды:
закрытия текущей вкладки;
закрытия всех вкладок, кроме текущей;
закрытия всех вкладок.

Закрыть текущую открытую вкладку также можно с помощью ярлыка
.
С помощью ярлыка
можно просмотреть список всех открытых вкладок.
Панель команд
Под списком вкладок отображается панель команд редактора визуализации. Часть команд доступна только при одновременном выделении нескольких элементов. Для этого нужно при зажатой ЛКМ обвести элементы рамкой или последовательно выделять элементы нажатием ЛКМ при зажатой клавише Ctrl.

Список команд редактора визуализации
Ярлык | Действие |
|---|---|
| Выровнять группу элементов по левому краю |
| Выровнять группу элементов по центру |
| Выровнять группу элементов по правому краю |
| Выровнять группу элементов по верхнему краю |
| Выровнять группу элементов по середине (по вертикали) |
| Выровнять группу элементов по нижнему краю |
| Закрепить выделенные элементы. Закрепленные элементы невозможно перемещать по экрану, вращать и изменять в размерах |
| Открепить элемент или группу элементов |
| Переместить выделенные элементы на одну ячейку сетки вверх |
| Переместить выделенные элементы на одну ячейку сетки вниз |
| Переместить выделенные элементы на одну ячейку сетки вправо |
| Переместить выделенные элементы на одну ячейку сетки влево |
| Центрировать группу элементов по вертикали |
| Центрировать группу элементов по горизонтали |
| Сгруппировать элементы. Сгруппированные элементы перемещаются по экрану и масштабируются как один цельный объект |
| Разгруппировать элементы |
| Сделать выделенные элементы равной ширины |
| Сделать выделенные элементы равной высоты |
| Переместить выделенные элементы в верхний слой |
| Переместить выделенные элементы в нижний слой |
| Переместить выделенные элементы на слой выше |
| Переместить выделенные элементы на слой ниже |
| Разместить выделенные элементы:
После выбора команды следует на экране/окне при зажатой ЛКМ начертить соответствующую геометрическую фигуру. Выделенные элементы будут расставлены в соответствии с контуром фигуры |
| |
| |
| |
| |
|
Сетка и масштаб
По умолчанию в редакторе визуализации отображается сетка, которая помогает позиционировать элементы. При перемещении элементы «притягиваются» к точкам сетки.

Цвет, шаг точек сетки и расстояние между ними настраиваются в меню Инструменты – Настройки конфигуратора.
Включение/отключение видимости сетки и изменение масштаба редактора визуализации (приближение/отдаление) производится с помощью ярлыков в строке информации.
Также изменить масштаб можно с помощью поворота колёсика мыши при зажатой клавише Ctrl.
Слои
Элементы могут располагаться в разных слоях.
Для перемещения элементов между слоями используются соответствующие ярлыки панели команд или команды контекстного меню элемента.

Элементы, размещённые в верхних слоях, перекрывают элементы, размещённые в нижних слоях.
Контекстное меню элемента
При нажатии ПКМ в свободном пространстве экрана/окна открывается меню настроек экрана.
При нажатии ПКМ на элемент открывается контекстное меню.

Команды контекстного меню элемента
Команды | Описание |
|---|---|
Группировать Разгруппировать | Данные команды доступны только при выделении нескольких элементов. Дублируют соответствующие команды панели команд |
Тиражировать | См. Тиражирование |
Сделать глобальным Сделать локальным | Данные команды доступны только для элементов экранов и недоступны для элементов окон.
По умолчанию элементы экрана являются локальными и отображаются только на данном экране. Глобальные элементы отображаются и функционируют на всех экранах проекта |
Вырезать Копировать Вставить Удалить | Дублируют соответствующие команды меню Правка |
Закрепить Открепить | Дублируют соответствующие команды панели команд |
| Слои | Дублируют соответствующие команды панели команд |
Свойства | Переход к свойствам элемента |
Команда Тиражировать позволяет создать копии выбранного элемента. При использовании команды открывается окно тиражирования, в котором необходимо указать следующие настройки:
количество строк и столбцов для создаваемых копий. Это влияет на количество копий (например, если указать 2 столбца и 3 строки, то будет создано 5 копий для выбранного элемента);
расстояние между создаваемыми элементами по оси X и Y;
режим увеличения адреса «основного» параметра элемента (расположенного на вкладке свойств Основное) – по горизонтали или по вертикали;
тип увеличиваемых адресов – регистры или биты регистров.

Карта адресов
Карта отображает адреса битов и регистров, используемых в проекте.

В верхней части окна находятся фильтры:
по типу адреса (бит или регистр);
по устройству (внутренние регистры или биты панели/регистры или биты одного из подключённых к панели slave-устройств);
по области памяти.
В карту попадают только биты и регистры, привязанные к графических элементам. В карте отображаются элементы всех экранов и окон проекта (независимо от того, открыты ли они в данный момент).
Ввод адреса и нажатие Enter или нажатие ЛКМ на ячейке карты выделяет ячейку. В нижней части экрана отображаются все вхождения адреса выделенной ячейки в проекте с указанием порядкового номера экрана/окна и идентификатора элемента.
Одиночное нажатие на строку приводит к выделению элемента в редакторе визуализации, двойное – к открытию меню свойств элемента.
Список элементов
Список элементов отображает элементы открытого в редакторе визуализации экрана/окна с указанием типов и идентификаторов.

Нажатие ЛКМ на элемент в списке приводит к его выделению.
Нажатие ПКМ открывает контекстное меню, содержащее команды Вырезать, Копировать, Вставить, Удалить и Свойства.
Для сгруппированного элемента использование команды Свойства приводит к открытию окна выбора меню свойств одного из элементов, входящего в состав группы.
С помощью команд
/
можно закрепить/открепить конкретный элемент или все элементы данного
экрана/окна. С помощью команд
/
можно скрыть/вернуть видимость выбранного элемента
или всех элементов данного экрана/окна.
Панель сообщений
Панель сообщений содержит две вкладки: Журнал и Ошибки.

На вкладке Журнал отображаются информационные сообщения о результате компиляции, а также другие сообщения (например, сообщения об автоматическом сохранении проекта, завершении процедуры тиражирования элементов и т. д.).
На вкладке Ошибки отображаются сообщения об ошибках компиляции. Такие сообщения разделены на три группы: ошибки, предупреждения и информационные сообщения. Нажатие на заголовок группы приводит к установке фильтра сообщений данной группы. Сообщения данной вкладки в большинстве случаев связаны с ошибками в коде макросов. Нажатие ЛКМ на строку сообщения приводит к переходу к файлу, в котором были обнаружены ошибки.
Строка информации
Строка информации расположена в нижней части окна конфигуратора.

Элементы строки информации
Элемент строки информации | Описание |
|---|---|
| IP-адрес панели. Двойное нажатие ЛКМ открывает окно сетевых настроек. ![]()
В двух последних вариантах заданные настройки будут записаны в панель при загрузке проекта. |
| Модель панели. Двойное нажатие ЛКМ открывает окно Настройки проекта – Панель. |
| Протоколы обмена, настроенные для коммуникационных интерфейсов панели. Если для интерфейса настроено несколько протоколов, то отображается только первый из них |
| Координаты курсора в редакторе визуализации |
| Кнопки изменения масштаба редактора визуализации |
| Кнопка отключения/включения видимости сетки в редакторе визуализации |
Инструменты – Настройки конфигуратора
Меню Инструменты – Настройки конфигуратора содержит настройки редактора визуализации и автоматического сохранения файла проекта.

На вкладке Редактор доступны следующие настройки:
Настройки вкладки
Настройка | Описание |
|---|---|
Отображать имена элементов | В случае установки галочки в элементе отображается его ID |
Размер текста | Размер текста, используемого для отображения ID, имён переменных и адресов элемента |
Цвет текста | Цвет текста, используемого для отображения ID, имён переменных и адресов элемента |
Отображать адреса устройств | В случае установки галочки в элементе отображаются имена переменных и адреса битов/регистров, привязанных к элементу |
Макс. кол-во | Максимальное количество имён переменных/адресов, отображаемых в элементе |
Отображать линии привязки | В случае установки галочки при перемещении элемента в редакторе визуализации отображаются линии привязки (snaplines), указывающие на его положение относительно других элементов |
На вкладке Сетка доступны следующие настройки:
Настройки вкладки Сетка
Настройка | Описание |
|---|---|
Отображать сетку | В случае установки галочки в редакторе визуализации отображается сетка |
Шаг сетки, X | Расстояние между точками сетки по оси X |
Шаг сетки, Y | Расстояние между точками сетки по оси Y |
Цвет сетки | Цвет точек сетки |
Закрепить все элементы | В случае установки галочки закрепляются все элементы всех экранов и окон проекта. Закрепленные элементы невозможно перемещать по экрану, вращать и изменять в размерах |
На вкладке Резервные копии доступны следующие настройки:
Настройки вкладки Резервные копии
Настройка | Описание |
|---|---|
Макс. кол-во копий | Максимальное количество резервных копий проекта. После достижения этого количества при создании новой копии самая старая будет удалена. Изменение настройки вступает в силу после перезапуска конфигуратора |
Включить автосохранение | В случае установки галочки с заданным периодом будет производиться создание резервной копии проекта |
Директория | Кнопка перехода в директорию резервной копии проекта (папка \BakDir в директории установки конфигуратора) |
Период сохранения | Период создания резервной копии проекта |
Название файла резервной копии формируется следующим образом:
OWEN@<метка времени создания файла><номер резервной копии>@<название файла проекта>@BackUp.xjp
На вкладке Наследование доступна галочка Наследовать настройки элементов. При установленной галочке новый добавленный графический элемент будет иметь те же настройки, что и последний отредактированный элемент данного типа.
Меню «Файл»
Меню Файл содержит команды для работы с проектом и эмулятором, а также команду перехода к настройкам проекта.

Список команд меню Файл
Команда | Описание |
|---|---|
Создать проект(Ctrl+N) | Создание нового проекта. При создании проекта требуется выбрать модификацию панели, после чего откроется окно Настройки проекта – Устройства, в котором можно настроить коммуникационные интерфейсы панели |
Открыть проект(Ctrl+O) | Открытие существующего проекта. Если в конфигураторе уже открыт проект, то нельзя открыть проект с тем же названием. С помощью фильтра указывается расширение файла проекта - .xjp (незашифрованный проект) или .xep (зашифрованный проект) |
Закрыть проект | Закрытие проекта |
Недавние проекты | Открытие одного из последних сохранённых проектов |
Сохранить | Сохранение проекта в том же файле |
Сохранить как | Сохранение проекта в виде нового файла |
Зашифровать проект | Сохранение проекта с установкой пароля в виде файла формата .xep. Длина пароля должна составлять от 6 до 20 символов. Зашифрованный проект можно открыть в конфигураторе, но его содержимое недоступно для просмотра и редактирования. Единственные поддерживаемые действия – загрузка в панель и запуск в режиме эмуляции |
Расшифровать проект | Расшифровка зашифрованного проекта, в ходе которой нужно ввести пароль, использованный при шифровании. Расшифрованный проект сохраняется в виде файла формата .xjp |
Компилировать проект (F7) | Компиляция проекта, в рамках которой производится проверка на ошибки. Информация о результате компиляции и ошибках отображается на панели сообщений |
Offline-эмуляция(Ctrl+T) | Запуск проекта на ПК в режиме offline-эмуляции |
Online-эмуляция(Ctrl+I) | Запуск проекта на ПК в режиме online-эмуляции |
Загрузить проект(Ctrl+D) | Загрузка проекта в панель или выгрузка проекта из панели. |
Создать загрузочный проект | Сохранение проекта в виде файла формата .dat, который может быть загружен в панель с USB-накопителя |
Сохранить эмуляцию | Сохранение online-эмуляции проекта в виде набора файлов. Это позволяет запустить эмуляцию на ПК, на котором не установлен конфигуратор. |
Снимок экрана | Сохранение скриншотов выбранных экранов/окон проекта в виде графических файлов (формата .png, .jpg или .bmp) или одного общего файла формата .pdf |
Данные PFW-регистров | Установка начальных значений для PFW-регистров панели. |
Настройки проекта (F5) | Переход к настройкам проекта |
Выход | Закрытие конфигуратора |
Меню «Правка»

В меню Правка доступны команды, которые можно использовать в редакторе визуализации при работе с графическими элементами:
копировать выделенные элементы в буфер обмена (Ctrl+C);
«вырезать» (копировать с удалением) выделенные элементы в буфер обмена (Ctrl+X);
вставить элементы из буфера обмена (Ctrl+V);
удалить выделенные элементы (Delete);
отменить последние изменения (Ctrl+Z);
восстановить последние изменения (Ctrl+Y).
Кроме того, доступны команды Поиск и замена адресов (Ctrl+F) и Поиск и замена шрифта.
Поиск и замена адресов
Команда Поиск и замена адресов позволяет найти и заменить адреса регистров или переменные, привязанные к элементам. Например, если в процессе работы возникла необходимость использовать для размещения параметров вместо области PSW область PFW (энергонезависимую) или поменять область памяти Modbus, в которой находятся параметры опрашиваемого slave-устройства.

В режиме Поиск следует указать:
Область поиска – весь проект или конкретный экран/окно;
Тип значения – бит или регистр;
Устройство – биты/регистры панели или одного из подключенных slave-устройств;
Область памяти;
Адрес или диапазон адресов битов/регистров .
Также можно осуществить поиск системной или пользовательской переменной с помощью установки соответствующей галочки.
После нажатия на кнопку Поиск в нижней части окна будет отображаться список всех найденных вхождений с указанием экрана/окна, идентификатора элемента и адреса привязанного объекта.
Двойное нажатие ЛКМ на строке приводит к выделению соответствующего элемента в редакторе визуализации.
Нажатие на кнопку Поиск приводит к выбору следующей строки списка.
В режиме Замена указываются те же параметры, что и для режима Поиск, а также устройство, область памяти и значение адреса, которые будут использоваться в процессе замены. Сначала следует нажать кнопку Поиск, а затем использовать кнопку Заменить для изменения настроек выбранной строки или Заменить всё для выполнения глобальной замены в рамках всего списка.
Если для поиска используется диапазон адресов, то в режиме замены доступна галочка Смещение адресов. В случае установки этой галочки к каждому из заменяемых адресов добавляется значение смещения. В случае отсутствия галочки каждый заменяемый адрес будет заменён на указанный адрес.
Пример использования функции замены с разными вариантами настроек
| Настройки поиска | Настройки замены | Результат замены |
|---|---|---|
| PSW, 0~2 | PFW, 0, галочка Смещение адресов не установлена | PSW0->PFW0 PSW1->PFW0 PSW2->PFW0 |
PFW, 0, галочка Смещение адресов установлена | PSW0->PFW1 PSW1->PFW2 PSW2->PFW3 | |
PFW, 1, галочка Смещение адресов установлена | PSW0->PFW2 PSW1->PFW3 PSW2->PFW3 |
Поиск и замена шрифта
Команда Поиск и замена шрифта позволяет найти элементы, в настройках которых указан выбранный шрифт, и заменить его на другой.

В режиме Поиск следует указать:
Шрифт
;Стиль шрифта – обычный, жирный, курсив или жирный курсив;
Область поиска – текущий экран/окно, выбранный экран/окно, все экраны/окна проекта или заданный диапазон экранов/окон. В случае установки галочки Включая системные в окне выбора будут доступны системные экраны/окна, а в случае выбора варианта Все – поиск будет производиться по всем экранам/окнам (в т. ч. и по системным).
После нажатия на кнопку Поиск в нижней части окна будет отображаться список всех найденных вхождений с указанием экрана/окна, идентификатора элемента, шрифта и его стиля. Двойное нажатие ЛКМ на строке приводит к выделению соответствующего элемента в редакторе визуализации.
В режиме Замена указываются те же параметры, что и для режима Поиск, а также шрифт и стиль, который будет использоваться для замены. Сначала следует нажать кнопку Поиск, а затем использовать кнопку Заменить для изменения настроек выделенных галочками элементов или Заменить всё для выполнения замены в рамках всего списка.
Настройки проекта
Меню настроек проекта содержит 8 вкладок:
Общие – содержит общие настройки панели;
Панель – позволяет изменить модификацию панели, выбранную в проекте;
Управление – позволяет указать регистры/переменные, которые будут использоваться для чтения номера текущего экрана панели и его переключения;
Права доступа – позволяет создавать пользователей;
Время – позволяет настроить способ получения системного времени панели;
Устройства – позволяет настроить коммуникационные интерфейсы панели;
Сканер штрихкодов – позволяет задать настройки интерфейса при подключении сканера штрихкодов;
Проект – позволяет указать автора проекта и комментарии.
Вкладка «Общие»

Настройки вкладки «Общие»
Параметр | Описание | Системный бит/регистр |
|---|---|---|
Начальный экран | Начальный экран, который будет открыт после запуска проекта | SPFW257 |
Заставка | Экран заставки, который будет открыт в случае заданного периода неактивности пользователя (задаётся в минутах). В случае установки галочки Отключить подсветку дисплея вместо перехода на экран заставки происходит отключение подсветки. В случае нажатия на экран заставки (или на экран с отключённой подсветкой) происходит переход на экран, который отображался до перехода на экран заставки или отключения подсветки | Период неактивности для заставки: SPFW258 Отключить подсветку: SPFW452 Флаг заставки: SPSB4 Флаг отключения подсветки: SPSB5 |
Курсор | Размеры и цвет пиктограммы курсора, отображаемого в месте нажатия на дисплей. В случае установки галочки Не отображать курсор отображаться не будет | SPFW449 (1 – отключить, 0 – включить) |
Звук | В случае установки галочки происходит отключение зуммера панели. В этом случае: | SPFW448 (1 – отключить, 0 – включить) |
Отображение элементов | В случае установки галочки элементы, к которым привязаны биты/регистры slave-устройства, отображаются сразу после запуска проекта до получения первого ответа от устройства (отображаются значения FALSE/0). В случае снятия галочки данные элементы будут отображены только после получения первого ответа от slave-устройства (отображаются считанные значения) |
|
Дополнительные настройки | В случае установки галочки Обнулять биты/регистры устройств при отсутствии связи – при отсутствии связи со slave-устройством в элементах, к которым привязаны его биты/регистры, отображаются значения FALSE/0. В случае снятия галочки отображаются последние считанные значения |
|
Вкладка «Панель»

Настройки вкладки «Панель»
Параметр | Описание |
|---|---|
Модель | Выбор модификации панели |
Описание | Технические характеристики выбранной модификации |
Режим масштабирования | Тип масштабирования элементов при выборе модификации, разрешение которой отличается от текущей модификации. Возможные варианты изменения ширины и высоты элементов:
|
Вкладка «Управление»

Настройки вкладки Управление
Параметр | Описание |
|---|---|
Переход на экран | Выбор адреса регистра или переменной, которая будет использоваться для переключения на экран с заданным номером. Номера экранов отображаются в дереве проекта. После переключения в параметр автоматически записывается значение 0 |
Номер открытого экрана | Выбор адреса регистра или переменной, в которую будет записываться номер открытого в данный момент экрана |
Вкладка «Права доступа»

На данной вкладке производится создание пользователей проекта. Для каждого пользователя нужно указать:
логин (не более 16 символов);
пароль (не более 8 символов, символы кириллицы не поддерживаются);
уровни доступа.
Уровни доступа позволяют ограничить:
возможность перехода на экран (см. параметр Уровень доступа);
возможность открытия окна;
видимость и активность графических элементов (см. настройки вкладки Безопасность).
Реализовано 30 независимых уровней доступа. Пользователю одновременно может быть назначено несколько. Уровни доступа не являются иерархическими: пользователю с уровнем 2 недоступны экраны, окна и элементы, для которых требуется уровень 1.
По умолчанию в проекте предусмотрен пользователь-администратор с логином admin и паролем по умолчанию 666666, которому предоставлены все уровни доступа. Администратора нельзя удалить. Дополнительно можно создать до 20 пользователей.
Для каждого пользователя может быть назначен бит авторизации. Этот бит принимает значение TRUE после авторизации данного пользователя. Если записать в этот бит значение FALSE – то будет выполнен выход из системы (логаут) пользователя. Для удаления этого бита используется кнопка Удалить бит.
Системный бит SPSB0:
принимает значение TRUE после авторизации любого из пользователей;
принимает значение FALSE после выхода пользователя из системы.
Системный бит SPSB1:
принимает значение TRUE после успешного выхода из системы любого пользователя;
принимает значение FALSE после успешной авторизации любого пользователя.
Для авторизации пользователя используется системное окно 25001, для изменения пароля – 25014. Пароли пользователей (за исключением администратора) сохраняются в системных регистрах (см. таблица) и могут быть изменены средствами проекта (например, с помощью макроса).
При переходе на экран заставки или отключении подсветки выход пользователя из системы не выполняется. При нажатии на экран заставки выполняется возврат на ранее открытый экран, даже если текущий уровень доступа оператора формально недостаточен для его отображения.
Вкладка «Время»

Настройки вкладки Время
Параметр | Описание |
|---|---|
Отключить возможность установки системного времени | В случае установки галочки у пользователя не будет возможности изменить системное время панели ни одним из доступных способов. Галочка автоматически устанавливается при активации функции Контроль оплаты |
Источник системного времени | Выбор источника системного времени. Возможные варианты: внутренние часы панели или регистр (в т. ч. можно указать регистр slave-устройства), начиная с которого размещаются значения разрядов системного времени в порядке: год, месяц, день, часы, минуты, секунды. Пользователь указывает формат разрядов системного времени – DEC или HEX |
Записать системное время в другое устройство | В случае установки галочки панель записывает значения разрядов системного времени во внутренние регистры или регистры одного или нескольких подключённых slave-устройств в порядке: год, месяц, день, часы, минуты, секунды. Пользователь указывает формат разрядов системного времени (DEC или HEX) и режим записи:
|
Данные PFW-регистров
С помощью команды Файл – Данные PFW-регистров пользователь может установить начальные значения, которые будут однократно записаны в PFW-регистры панели после первого запуска проекта.
В данном окне пользователь добавляет группы регистров, указывая для каждой начальный и конечный адрес. Диапазоны адресов разных групп не могут пересекаться. Для изменения диапазона следует выделить группу, ввести новые значения начального и конечного адреса, после чего нажать кнопку Применить.
Для ввода значений регистров следует два раза нажать ЛКМ на группу или выделить группу и нажать кнопку Изменить. Откроется окно, в котором можно ввести значения для каждого из регистров группы в выбранном формате (DEX или HEX), нажав на ячейку регистра. C помощью кнопок Установить в 0 и Установить в 0xFFFF можно записать во все регистры соответствующее значение.
Для ввода значений типа Float потребуется представить их в виде двух HEX-значений. Для этого удобно использовать онлайн-конвертер: https://www.h-schmidt.net/FloatConverter/IEEE754.html
Для ввода строковых значений потребуется представить их в виде набора байт: https://crypt-online.ru/crypts/text2hex/
В примерах ниже показана инициализация PFW-регистров с размещением значений типа Float и String (кодировка Win1251). Обратите внимание на отличие в порядке байт между вводимым и отображаемым в конвертере значениями.








































