---
title: "Руководство пользователя программой «Конфигуратор М110»"
product: "Модули дискретного ввода (с интерфейсом RS-485) МВ110"
document_number: "№ 1-RU-57090-1.1"
version: "1.1"
language: "ru"
source: "https://docs.owen.ru/product/moduli_diskretnogo_vvoda_s_interfejsom_rs_485/doc/rukovodstvo-polzovatela-programmoj-konfigurator-m1_2"
pdf: "https://docs.owen.ru/download/pdf/8KLiX.rp_konfigurator+m110_1-ru-57090-1.1.pdf"
generated: "2026-10-10"
---

# Руководство пользователя программой «Конфигуратор М110»

## Содержание

- [О программе](#topic-12028)
- [Требования к ПК](#topic-12029)
- [Установка программы](#topic-12030)
- [Запуск программы](#topic-12031)
  - [Установка связи с прибором](#topic-12032)
  - [Режим работы без подключения прибора (режим «offline»)](#topic-12033)
- [Главное окно программы](#topic-12034)
  - [Меню, панель инструментов и горячие клавиши программы](#topic-12035)
- [Работа с программой](#topic-12036)
  - [Создание новой конфигурации](#topic-12037)
  - [Открытие конфигурации из файла](#topic-12038)
  - [Редактирование значений параметров](#topic-12039)
  - [Считывание конфигурации из прибора](#topic-12040)
  - [Запись значений параметров в прибор](#topic-12041)
  - [Анализ входов и выходов прибора](#topic-12042)
  - [Применение параметров](#topic-12043)
  - [Сохранение конфигурации в файл](#topic-12044)
  - [Выход из программы](#topic-12045)

<a id="topic-12028"></a>

## О программе

Программа «Конфигуратор М110» предназначена для считывания, изменения и записи в энергонезависимую память приборов серии Мх110 рабочих параметров, а также создания файла-конфигурации с полученными параметрами для последующего использования.

Связь прибора по интерфейсу RS-485 выполняется по двухпроводной схеме. Длина линии связи должна быть не более 1200 метров.

Обмен между прибором и программой происходит по протоколу **ОВЕН**.

<a id="topic-12029"></a>

## Требования к ПК

Для работы с программой должны быть предоставлены следующие аппаратурные и программные средства:

- компьютер с установленной операционной системой Microsoft Windows 95/98/Me/NT/2000/XP/7/8/10 с поддержкой русского языка;
- быстродействие процессора и размер оперативной памяти должны соответствовать требованиям операционной системы;
- свободное место на жестком диске — не менее 10 Мб;
- видеокарта и монитор SVGA с поддержкой видеорежима с глубиной цвета не хуже 256 цветов (рекомендуется 65536 цветов, разрешение 1200х1024);
- подключенный к компьютеру преобразователь RS-232/RS-485 (например, ОВЕН АС3–М) или USB/RS-485 (например, ОВЕН АС4);
- кабель типа «витая пара».

<a id="topic-12030"></a>

## Установка программы

Для установки программы «Конфигуратор М110» следует:

1. Скачать файл с актуальной версией программы с сайта [www.owen.ru](http://www.owen.ru) и запустить его.

2. В открывшемся окне нажать кнопку **«Далее»**.

   ![1](https://docs.owen.ru/book_img/253/56999.png)

   *Мастер установки «Конфигуратор М110»*

3. Указать папку на жестком диске, в которую будет установлена программа, и нажать кнопку **«Далее»**.

   ![2](https://docs.owen.ru/book_img/253/56998.png)

   *Выбор папки установки*

4. Указать папку в меню «Пуск», в которой будет создан ярлык программы, и нажать кнопку **«Далее»**.

   ![3](https://docs.owen.ru/book_img/253/56997.png)

   *Выбор папки в меню «Пуск»*

5. Указать, будет ли при завершении установки создан ярлык на рабочем столе, и нажать кнопку **«Далее»**.

   ![4](https://docs.owen.ru/book_img/253/56996.png)

   *Создание иконки на рабочем столе*

6. Проверить указанные ранее параметры установки и нажать кнопку **«Установить»**.

   ![5](https://docs.owen.ru/book_img/253/56995.png)

   *Проверка параметров установки*

7. Указать, будет ли программа запущена сразу после завершения установки, и нажать кнопку **«Завершить»**.

   ![6](https://docs.owen.ru/book_img/253/56994.png)

   *Завершение установки*

<a id="topic-12031"></a>

## Запуск программы

Для запуска программы следует выбрать команду **Пуск → Программы → OWEN → Конфигуратор М110 → Конфигуратор М110** либо два раза щелкнуть левой кнопкой «мыши» по ярлыку программы (если в ходе установки было выбрано создание иконки на рабочем столе).

После запуска программа «Конфигуратор М110» устанавливает связь с прибором. Установка связи происходит при значениях параметров порта, установленных при предыдущем запуске программы.

Если связь с прибором установлена, откроется главное окно программы [Главное окно программы](#topic-12034).

Если связь с прибором не установлена, откроется окно **«Установка связи с прибором»** [Установка связи с прибором](#topic-12032).

<a id="topic-12032"></a>

### Установка связи с прибором

В окне **«Установка связи с прибором»** отображается информация о текущих значениях параметров порта, в левой части окна представлены наименования параметров порта, в правой — значения параметров.

![Рисунок 1](https://docs.owen.ru/book_img/253/56992.png)

*Окно установки связи с прибором*

Если значения параметров известны, следует задать их значения. Для изменения значения параметра следует перевести поле ячейки таблицы в режим редактирования двойным щелчком на требуемой строке списка параметров в столбце **«Значение»**. В зависимости от типа редактируемого параметра новое значение может быть либо введено с клавиатуры (например, **«Базовый адрес прибора»**), либо выбрано из раскрывающегося списка (например, **«Порт компьютера»**). После задания требуемых значений параметров программы следует нажать кнопку **«Установить связь»**. При отклике прибора процедура установки связи прекращается.

Если значения параметров порта не известны, следует нажать кнопку **«Сканирование сети»** и запустить процедуру сканирования с перебором скоростей обмена, начиная со скорости обмена 2400 бит/с, и далее до скорости 115200 бит/с. Остальные параметры порта (четность, длина слова данных и др.) в процессе сканирования не меняются. При отклике прибора сканирование прекращается.

Если установить связь с прибором не удается, необходимо восстановить заводские значения параметров прибора (см. руководство по эксплуатации), нажать кнопку **«Заводские сетевые настройки»** и повторить попытку установить связь.

Кнопка **«Выход»** предназначена для выхода из программы.

<a id="topic-12033"></a>

### Режим работы без подключения прибора (режим «offline»)

Для работы с программой без подключения прибора в окне **«Установка связи с прибором»** нажать на кнопку **«Работать offline»**. Откроется окно **«Выберите прибор»**.

![Рисунок 2](https://docs.owen.ru/book_img/253/56991.png)

*Окно выбора прибора для работы с конфигурацией Offline*

В раскрывшемся списке, содержащим названия всех приборов серии М110, необходимо выбрать название нужного прибора и нажать кнопку **«ОК»**. Откроется главное окно программы [Главное окно программы](#topic-12034). При этом режим автоматического чтения параметров следует отключить [Считывание конфигурации из прибора](#topic-12040).

Для перехода из окна выбора прибора обратно в окно установки связи с прибором нажать кнопку **«Отмена»**.

<a id="topic-12034"></a>

## Главное окно программы

Вид главного окна программы представлен на рисунке. В заголовке окна отображается запись **«Конфигуратор М110»**, название прибора и наименование текущей конфигурации прибора. Ниже находится меню выбора команд и кнопки панели инструментов. Центральная область окна — рабочее поле программы — содержит параметры, собранные в группы, их наименования, значения, атрибут редактирования, информацию о владельце, информацию об ошибке обмена и несоответствия.

![Рисунок 3](https://docs.owen.ru/book_img/253/56993.png)

*Главное окно программы*

При работе с иерархически организованным перечнем параметров, чтобы развернуть перечень, следует щелкнуть по значку «плюс» около названия свернутого пункта; чтобы свернуть — по значку «минус» около названия развернутого пункта перечня.

В нижней части окна слева отображается сообщение «Для вызова справки нажмите F1».

Сообщение NUM в нижней правой части окна индицирует, что включена кнопка «NumLock» на клавиатуре.

Управление программой производится посредством выбора команд меню, нажатия кнопок панели управления или горячих клавиш.

<a id="topic-12035"></a>

### Меню, панель инструментов и горячие клавиши программы

Пункты меню «Конфигуратор М110», кнопки панели инструментов (**КН**) и горячие клавиши (**ГК**) представлены в таблице 5.1.

**Пункты меню «Конфигуратор М110»**

| Пункт меню | КН | ГК | Описание |
| --- | --- | --- | --- |
| **Файл → Новый** | ![Табл 1](https://docs.owen.ru/book_img/253/57024.png) | **Ctrl+N** | Создание новой конфигурации прибора [Создание новой конфигурации](#topic-12037) |
| **Файл → Открыть** | ![Табл 2](https://docs.owen.ru/book_img/253/57049.png) | **Ctrl+O** | Открытие файла конфигурации — \*.m110 [Открытие конфигурации из файла](#topic-12038) |
| **Файл → Сохранить** | ![Табл 3](https://docs.owen.ru/book_img/253/57047.png) | **Ctrl+S** | Сохранение конфигурации в файл [Сохранение конфигурации в файл](#topic-12044) |
| **Файл → Сохранить как** |   |   | Сохранение конфигурации в файл с другим именем [Сохранение конфигурации в файл](#topic-12044) |
| **Файл → Последние файлы** |   |   | Быстрый доступ к последним четырем файлам конфигурации |
| **Файл → Выход** |   |   | Выход из программы [Выход из программы](#topic-12045) |
| **Прибор → Прочитать все параметры** | ![Табл 4](https://docs.owen.ru/book_img/253/57045.png) | **Alt+R** | Считывание значений всех параметров из прибора в программу [Считывание конфигурации из прибора](#topic-12040) |
| **Прибор → Записать все параметры** | ![Табл 5](https://docs.owen.ru/book_img/253/57044.png) | **Alt+W** | Запись всех параметров из программы в прибор [Запись значений параметров в прибор](#topic-12041) |
| **Прибор → Записать только измененные** | ![Табл 6](https://docs.owen.ru/book_img/253/57043.png) | **Alt+U** | Запись измененных значений параметров из программы в прибор [Запись значений параметров в прибор](#topic-12041). Измененные значения параметра отображаются зеленым шрифтом, записанные в прибор — черным |
| **Прибор → Сравнить с реальными значениями** |   | **Alt+C** | Сравнение значений параметров прибора и открытой конфигурации [Считывание конфигурации из прибора](#topic-12040) |
| **Прибор → Сервис → Инициализировать прибор** | ![Табл 7](https://docs.owen.ru/book_img/253/57042.png) |   | Применение параметров базовой заводской конфигурации, кроме сетевых параметров [Применение параметров](#topic-12043) |
| **Прибор → Сервис → Послать команду INIT** | ![Табл 8](https://docs.owen.ru/book_img/253/57066.png) | **Alt+I** | Применение установленных параметров [Применение параметров](#topic-12043) |
| **Прибор → Сервис → Послать команду APPLY** |   | **Alt+A** | Применение установленных сетевых параметров [Применение параметров](#topic-12043) |
| **Прибор → Состояние входов (выходов)** | ![Табл 9](https://docs.owen.ru/book_img/253/57065.png) |   | Опрос состояния входов прибора в новом окне [Анализ входов и выходов прибора](#topic-12042) |
| **Прибор → Опрос отдельного параметра** |   | **Alt+S** | Доступ к отдельным параметрам прибора (в новом окне) для чтения [Считывание конфигурации из прибора](#topic-12040) или записи [Запись значений параметров в прибор](#topic-12041) |
| **Прибор → Проверка связи с прибором** |   | **Alt+N** | Считывание имени прибора и номера версии программы прибора, проверка связи с прибором (с открытием нового информационного окна с номером версии программы, именем прибора или сообщением об ошибке) |
| **Прибор → Преобразователь → Полуавтоматический (АСЗ) / Автоматический** |   |   | Выбор (с установкой маркера) типа преобразователя RS-485/RS-232:<br>• полуавтоматический (АСЗ) — для связи с прибором через полуавтоматические (например, ОВЕН АСЗ) и автоматические преобразователи;<br>• автоматический — для связи с прибором через автоматические преобразователи (обмен информацией происходит быстрее, но работа с полуавтоматическими преобразователями невозможна) |
| **Прибор → Настройка порта** |   |   | Вызов окна установки связи с прибором [Установка связи с прибором](#topic-12032) |
| **Дерево → Прочитать все параметры выделенной ветви** | ![Табл 10](https://docs.owen.ru/book_img/253/57061.png) | **Ctrl+Alt+N** | Считывание из прибора значений параметров выделенной ветви [Считывание конфигурации из прибора](#topic-12040) |
| **Дерево → Записать все параметры выделенной ветви** | ![Табл 11](https://docs.owen.ru/book_img/253/57080.png) | **Ctrl+Alt+W** | Запись всех параметров выделенной ветви в прибор [Запись значений параметров в прибор](#topic-12041) |
| **Дерево → Записать только измененные параметры выделенной ветви** | ![Табл 12](https://docs.owen.ru/book_img/253/57079.png) | **Ctrl+Alt+U** | Запись только измененных значений параметров выделенной ветви в прибор [Запись значений параметров в прибор](#topic-12041) |
| **Дерево → Сравнить значения с реальными в рамках ветви** |   | **Ctrl+Alt+C** | Сравнение значений параметров выделенной ветви и открытой конфигурации с открытием окна монитора процесса [Запись значений параметров в прибор](#topic-12041) |
| **Дерево → К предыдущему проблемному параметру → К следующему проблемному параметру** | ![Табл 13](https://docs.owen.ru/book_img/253/57078.png) | **Alt+↑** | Поочередный переход (вверх или вниз по списку) к ошибочно считанным [Считывание конфигурации из прибора](#topic-12040) или записанным параметрам [Запись значений параметров в прибор](#topic-12041) |
| **Дерево → К предыдущему проблемному параметру → К следующему проблемному параметру** | ![Табл 14](https://docs.owen.ru/book_img/253/57077.png) | **Alt+↓** | Поочередный переход (вверх или вниз по списку) к ошибочно считанным [Считывание конфигурации из прибора](#topic-12040) или записанным параметрам [Запись значений параметров в прибор](#topic-12041) |
| **Режимы программы → Показать линейные индексы** |   |   | Отображение (при установленном маркере) линейных индексов параметров, которые необходимы при создании новых программ, работающих с прибором [Считывание конфигурации из прибора](#topic-12040) |
| **Режимы программы → Режим автоматического чтения** |   |   | Автоматическое считывание из прибора значений параметров открываемой папки (при установленном маркере), режим включен при запуске программы [Считывание конфигурации из прибора](#topic-12040) |
| **Режимы программы → Режим немедленной записи** |   |   | Автоматическая запись (при установленном маркере) в память прибора изменяемых параметров [Запись значений параметров в прибор](#topic-12041) |
| **Режимы программы → Не передавать атрибуты параметров** |   |   | Обмен информацией об индивидуальных защитных атрибутах параметров не производится [Запись значений параметров в прибор](#topic-12041) |
| **Режимы программы → Юстировка** |   |   | Переход к юстировке прибора (в новом окне). Юстировка описана в руководстве по эксплуатации |
| **Режимы программы → Панель инструментов** |   |   | Отображение панели инструментов главного окна программы (при установленном маркере) |
| **Режимы программы → Панель состояния** |   |   | Отображение панели состояния главного окна программы (при установленном маркере) |
| **Справка → Справка** |   | **F1** | Вызов окна электронной контекстной справки программы |
| **Справка → Экспорт списка параметров в HTML** |   |   | Запуск процедуры формирования списка текущих параметров конфигурации в файл HTML (в новом окне программы-браузера) с возможностью сохранения файла \*.html или \*.txt |
| **Справка → О программе** | ![Табл 15](https://docs.owen.ru/book_img/253/57076.png) |   | Отображение информации о программе и ее версии (в новом окне) |

<a id="topic-12036"></a>

## Работа с программой

<a id="topic-12037"></a>

### Создание новой конфигурации

Для создания новой конфигурации выбирается команда **Файл → Новый**.

![Безымянный23](https://docs.owen.ru/book_img/253/57023.png)

*Файл → Новый*

Откроется главное окно программы с корневым каталогом **Конфигурация М110 (Имя не задано)**. Развернув дерево параметров, следует ввести требуемые значения [Редактирование значений параметров](#topic-12039). Созданная конфигурация может быть сохранена в файл [Сохранение конфигурации в файл](#topic-12044) или записана в прибор [Запись значений параметров в прибор](#topic-12041).

<a id="topic-12038"></a>

### Открытие конфигурации из файла

Для открытия конфигурации из файла выбирается команда **Файл → Открыть**.

![Безымянный24](https://docs.owen.ru/book_img/253/57048.png)

*Файл → Открыть*

Откроется стандартное окно выбора файла, в котором следует выбрать файл конфигурации и нажать кнопку **«Открыть»**. В заголовке главного окна программы и рядом с корневой папкой программы отобразится имя открытого файла, значения параметров будут соответствовать параметрам, заданным в выбранном файле.

<a id="topic-12039"></a>

### Редактирование значений параметров

Для изменения значения редактируемого параметра (с атрибутом «редактируемый» в столбце **«Атрибут редактирования»**) следует дважды щелкнуть левой кнопкой «мыши» в требуемой строке столбца **«Значение»**. Поле ячейки таблицы перейдет в режим редактирования и значение может быть изменено.

Требуемое значение параметра вводится с клавиатуры или выбирается из раскрывающегося списка. Для завершения ввода с клавиатуры следует нажать кнопку **«Enter»** на клавиатуре.

![Рисунок 5](https://docs.owen.ru/book_img/253/57022.png)

*Выбор параметра*

Измененные значения отображаются зеленым цветом и сохраняются только в памяти программы.

Если введен некорректный параметр (например, вне допустимого диапазона), то отображается информационное окно с соответствующим сообщением об ошибке.

<a id="topic-12040"></a>

### Считывание конфигурации из прибора

Для считывания конфигурации из прибора предусмотрены следующие режимы:

- режим считывания информации о приборе;
- режим считывания всех параметров;
- режим считывания параметров выделенной ветви;
- режим автоматического чтения;
- режим опроса отдельного параметра;
- режим работы с линейными индексами;
- режим работы с проблемными параметрами;
- режим сравнения параметров конфигурации и прибора.

**Режим считывания информации о приборе.**

Для считывания имени прибора, исполнения прибора, номера версии программы и проверки связи с прибором выбирается команда **Прибор → Проверка связи с прибором**. Открывается информационное окно с информацией о приборе или с сообщением об ошибке.

![Безымянный25](https://docs.owen.ru/book_img/253/57020.png)

*Прибор → Проверка связи с прибором*

**Режим считывания всех параметров.**

Для перехода в режим выбирается команда **Прибор → Прочитать все параметры**. Считывание всех параметров из прибора сопровождается открытием окна мониторинга процесса, закрывающегося при завершении процесса. В рабочем поле программы отобразятся считанные значения.

![Рисунок 6](https://docs.owen.ru/book_img/253/57019.png)

*Прибор → Прочитать все параметры*

![Рисунок 7](https://docs.owen.ru/book_img/253/57018.png)

*Окно мониторинга процесса*

**Режим считывания параметров выделенной папки.**

Для перехода в режим выделить требуемую папку параметров, выбрать команду **Дерево → Прочитать все параметры выделенной ветви**. Или, выделив требуемую папку параметров, щелкнуть правой кнопкой «мыши», из раскрывающегося списка выбрать команду **«Прочитать параметры ветви»**. Считывание параметров из прибора сопровождается открытием окна мониторинга процесса, закрывающегося при завершении процесса. В рабочем поле программы отобразятся считанные значения.

![Рисунок 8](https://docs.owen.ru/book_img/253/57017.png)

*Дерево → Прочитать параметры выделенной ветви*

![Рисунок 9](https://docs.owen.ru/book_img/253/57016.png)

*Команда «Прочитать параметры ветви»*

**Режим автоматического чтения.**

Режим автоматического чтения позволяет автоматически считать значения группы параметров, содержащихся в открываемой папке. Считывание параметров в этом режиме возможно, если ранее значения параметров из прибора считаны не были (в поле **«Значение»** было указано **«Нет данных»**). При запуске программы этот режим включается по умолчанию. Для его отключения следует снять маркер в меню **Режимы программы → Режим автоматического чтения**.

![Рисунок 11](https://docs.owen.ru/book_img/253/57015.png)

*Режимы программы → Режим автоматического чтения*

> [!NOTE]
> **Примечание.** При работе без подключенного прибора (в режиме **«offline»**) режим автоматического чтения рекомендуется отключить.

**Режим опроса отдельного параметра.**

Для считывания одного выбранного параметра необходимо подать команду **Прибор → Опрос отдельного параметра**. В открывшемся окне выбрать в графе **«Определите команду»** из раскрывающегося списка имя параметра. Справа отображается название параметра, ниже — hash-код. Далее следует выбрать операцию **«Чтение»** путем установки маркера и нажать кнопку **«Выполнить!»**. В области окна **«Протокол обмена данными с прибором»** отображается процесс чтения.

![Безымянный11](https://docs.owen.ru/book_img/253/57014.png)

*Прибор → Опрос отдельного параметра*

![Безымянный12](https://docs.owen.ru/book_img/253/57013.png)

*Окно опроса отдельного параметра*

Второй способ считывания одного выбранного параметра — щелкнуть правой кнопкой «мыши» в требуемой строке параметра и выбрать команду **«Прочитать параметр»**. Считывание параметра из прибора сопровождается открытием окна мониторинга процесса, закрывающегося при завершении процесса.

![Рисунок 12](https://docs.owen.ru/book_img/253/57012.png)

*Команда «Прочитать параметр»*

![Рисунок 13](https://docs.owen.ru/book_img/253/57011.png)

*Окно мониторинга процесса*

**Режим работы с линейными индексами.**

Для работы с линейными индексами, необходимыми при создании новых программ, следует подать команду **Режимы программы → Показывать линейные индексы**.

![Безымянный](https://docs.owen.ru/book_img/253/57030.png)

*Режимы программы → Показывать линейные индексы*

**Режим работы с проблемными параметрами.**

Если при считывании параметра произошла ошибка, он отображается красным цветом. При выборе команды **Дерево → К предыдущему проблемному параметру** или **Дерево → К следующему проблемному параметру** происходит поочередный переход к ошибочно считанным параметрам.

![Безымянный2](https://docs.owen.ru/book_img/253/57029.png)

*Дерево → К предыдущему (следующему) проблемному параметру*

**Режим сравнения параметров конфигурации и прибора.**

Для перехода в режим сравнения всех параметров следует выбрать команду **Прибор → Сравнить с реальными значениями**.

![Безымянный3](https://docs.owen.ru/book_img/253/57028.png)

*Прибор → Сравнить с реальными значениями*

Для перехода в режим сравнения параметров в рамках выделенной ветви следует выбрать команду **Дерево → Сравнить значения с реальными в рамках ветви**.

![Безымянный4](https://docs.owen.ru/book_img/253/57027.png)

*Дерево → Сравнить значения с реальными в рамках ветви*

Также в режим можно перейти, щелкнув правой кнопкой «мыши» и выбрав из раскрывающегося списка команду **«Сравнить с реальными значениями»**. Сравнение значений параметров сопровождается открытием окна мониторинга процесса, закрывающегося при завершении процесса, после чего отобразится окно информационного сообщения (например, **«Отличий не обнаружено»**).

![Безымянный5](https://docs.owen.ru/book_img/253/57026.png)

*Команда «Сравнить с реальными значениями»*

![Рисунок 14](https://docs.owen.ru/book_img/253/57025.png)

*Окно мониторинга процесса*

<a id="topic-12041"></a>

### Запись значений параметров в прибор

Для записи конфигурации в прибор предусмотрены следующие режимы:

- режим записи всех параметров;
- режим записи только измененных параметров;
- режим записи параметров выделенной папки;
- режим записи отдельного параметра;
- режим работы с линейными индексами;
- режим работы без передачи атрибутов параметров;
- режим работы с проблемными параметрами.

**Режим записи всех параметров.**

Для перехода в режим выбирается команда **Прибор → Записать все параметры**. Откроется информационное окно процесса записи всех параметров. После его автоматического закрытия измененные параметры, отображаемые зеленым цветом, будут отображаться черным цветом.

![Безымянный7](https://docs.owen.ru/book_img/253/57039.png)

*Прибор → Записать все параметры*

![Рисунок 15](https://docs.owen.ru/book_img/253/57038.png)

*Окно процесса записи параметров в прибор*

**Режим записи только измененных параметров.**

Для перехода в режим необходимо выбрать команду **Прибор → Записать только измененные**. Для записи измененных параметров в рамках ветви, выделив требуемую папку параметров, щелкнуть правой кнопкой «мыши», из раскрывающегося списка выбрать команду **«Записать только измененные»**. Откроется информационное окно процесса записи измененных параметров. После его автоматического закрытия измененные параметры, отображаемые зеленым цветом, будут отображаться черным цветом. Запись в этом режиме осуществляется быстрее, чем при записи всех параметров.

![Безымянный8](https://docs.owen.ru/book_img/253/57037.png)

*Прибор → Записать только измененные*

![Безымянный9](https://docs.owen.ru/book_img/253/57036.png)

*Команда «Записать только измененные»*

**Режим записи параметров выделенной папки.**

Для перехода в режим следует щелкнуть правой кнопкой «мыши» по требуемой папке и из раскрывающегося списка выбрать команду **«Записать параметры ветви»**. Откроется информационное окно процесса записи измененных параметров. После его автоматического закрытия измененные параметры, отображаемые зеленым цветом, будут отображаться черным цветом.

![Безымянный10](https://docs.owen.ru/book_img/253/57035.png)

*Команда «Записать параметры ветви»*

**Режим записи отдельного параметра.**

Для записи одного выбранного параметра необходимо подать команду **Прибор → Опрос отдельного параметра**. В открывшемся окне в графе **«Определите команду»** следует выбрать имя параметра из раскрывающегося списка. Справа отображается название параметра, ниже — hash-код. Далее следует выбрать операцию **«Записать»** путем установки маркера и значение параметра в графе **«Что записать»**, а затем нажать кнопку **«Выполнить!»**. В области окна **«Протокол обмена данными с прибором»** отображается процесс записи.

![Безымянный11](https://docs.owen.ru/book_img/253/57014.png)

*Прибор → Опрос отдельного параметра*

![Рисунок 10](https://docs.owen.ru/book_img/253/57034.png)

*Окно опроса отдельного параметра*

Другой способ записи одного выбранного параметра — щелкнуть правой кнопкой «мыши» в требуемой строке параметра, выбрать команду **«Записать параметр»**. Запись параметра сопровождается открытием окна мониторинга процесса, закрывающегося при завершении процесса. Если значение параметра неизвестно, то следует выбрать команду **«Установить значение “Нет данных”»**.

![Безымянный13](https://docs.owen.ru/book_img/253/57033.png)

*Команда «Записать параметр»*

![Безымянный14](https://docs.owen.ru/book_img/253/57032.png)

*Команда «Установить значение в “Нет данных”»*

**Режим работы с линейными индексами.**

Для работы с линейными индексами, необходимыми при создании новых программ, следует подать команду **Режимы программы → Показывать линейные индексы**.

![Безымянный](https://docs.owen.ru/book_img/253/57030.png)

*Режимы программы → Показывать линейные индексы*

**Режим работы без передачи атрибутов параметров.**

Для выбора режима работы программы без передачи атрибутов параметров выбрать команду **Режимы программы → Не передавать атрибуты параметров** путем установки маркера, после чего открывается окно предупредительного сообщения.

![Безымянный15](https://docs.owen.ru/book_img/253/57031.png)

*Режимы программы → Не передавать атрибуты параметров*

![Рисунок 17](https://docs.owen.ru/book_img/253/57050.png)

*Предупредительное сообщение*

**Режим работы с проблемными параметрами.**

Если при записи параметра произошла ошибка, он отображается красным цветом. При выборе команды **Дерево → К предыдущему проблемному параметру** или **Дерево → К следующему проблемному параметру**происходит поочередный переход к ошибочно записанным параметрам.

![Безымянный2](https://docs.owen.ru/book_img/253/57029.png)

*Дерево → К предыдущему (следующему) проблемному параметру*

<a id="topic-12042"></a>

### Анализ входов и выходов прибора

Приборы серии Мх110 могут иметь один или несколько входов, выходов или входов и выходов. Для опроса состояния входов и выходов прибора следует выбрать команду **Прибор → Состояние входов и выходов**, после чего открывается окно опроса состояния входов и выходов. Опрос входов и выходов ведется поочередно, считываемые значения отображаются зеленым цветом.

![Безымянный17](https://docs.owen.ru/book_img/253/57064.png)

*Прибор → Состояние входов и выходов*

![Рисунок 18](https://docs.owen.ru/book_img/253/57063.png)

*Состояние входов и выходов*

В верхней части окна отображается информация о состоянии входов и выходов в соответствующих пронумерованных прямоугольниках.

В зависимости от состояния входов прямоугольники с номерами входов отображаются разным цветом: цветом фона при разомкнутом состоянии, бежевым — при замкнутом.

В зависимости от состояния выходов прямоугольники с номерами выходов отображаются следующим образом: цветом фона при значении на выходе, равном 0 (например, скважность ШИМ или параметр ЦАП); зеленым — при значении на выходе, равном 1; заштрихованным — при параметре в диапазоне от 0 до 1.

В нижней части области окна в столбце **«Значение»** отображается информация о параметрах на входах и выходах.

Для входов поля колонки **«Обнуление»** содержит кнопки **«Сброс»**, нажатие которых производит установку в счетчики нулевого значения.

В области **«Выходы»** возможно задать выходные параметры (скважность ШИМ, параметр ЦАП), включить или выключить выход. Для этого следует дважды щелкнуть левой кнопкой «мыши» на требуемом поле колонки **«Значение»**, тогда значение в этом поле переключится в режим редактирования и может быть изменено. Параметры выходов задаются в диапазоне от 0 до 1 включительно.

Для некоторых приборов опрос входов и выходов реализован в рабочем поле программы. Для опроса требуемого входа или выхода следует установить маркер в раскрывающемся списке напротив интересующего входа или выхода, группы входов или выходов или параметра.

![Рисунок 19](https://docs.owen.ru/book_img/253/57062.png)

*Опрос входов в рабочем поле программы*

При необходимости следует изменить период опроса входов и выходов, дважды щелкнув левой кнопкой «мыши» в ячейке **«Период»** требуемой строки. Значение периода опроса переходит в режим редактирования и может быть изменено. По умолчанию период опроса составляет 1000 мс.

Считываемые значения отображаются в колонке **«Значение»**.

> [!NOTE]
> **Примечание.** В случае реализации опроса входов и выходов в рабочем поле программы команда **Прибор → Состояние входов и выходов** неактивна.

<a id="topic-12043"></a>

### Применение параметров

Для применения записанных в прибор параметров и записи их в энергонезависимую память следует выбрать команду **Прибор → Сервис → Послать команду INIT**, после чего открывается предупредительное окно.

![Безымянный18](https://docs.owen.ru/book_img/253/57041.png)

*Прибор → Сервис → Послать команду INIT*

![Рисунок 21](https://docs.owen.ru/book_img/253/57070.png)

*Предупредительное окно INIT*

Для применения новых сетевых настроек прибора следует выбрать команду **Прибор → Сервис → Послать команду APLY**, после чего открывается предупредительное окно.

![Безымянный19](https://docs.owen.ru/book_img/253/57069.png)

*Прибор → Сервис → Послать команду APLY*

![Рисунок 22](https://docs.owen.ru/book_img/253/57068.png)

*Предупредительное окно APLY*

Для применения заводских настроек прибора следует выбрать команду **Прибор → Сервис → Инициализировать прибор**.

![Безымянный20](https://docs.owen.ru/book_img/253/57067.png)

*Прибор → Сервис → Инициализировать прибор*

<a id="topic-12044"></a>

### Сохранение конфигурации в файл

Для сохранения конфигурации в файл следует выбрать команду **Файл → Сохранить → Сохранить как**. Отроется стандартное диалоговое окно, в котором следует задать имя и место расположения файла на диске. Команда **Файл → Сохранить** позволяет сохранить файл под существующим именем. Файл конфигурации имеет расширение **\*.m110**.

![Безымянный21](https://docs.owen.ru/book_img/253/57021.png)

*Файл → Сохранить как*

Для сохранения перечня параметров в html-файл или в текстовый файл выбрать **Справка → Экспорт списка параметров в HTML**.

![Рисунок 23](https://docs.owen.ru/book_img/253/57040.png)

*Справка → Экспорт списка параметров в HTML*

<a id="topic-12045"></a>

### Выход из программы

Для выхода из главного меню программы следует выбрать команду **Файл → Выход**.

![Безымянный22](https://docs.owen.ru/book_img/253/57046.png)

*Файл → Выход*
